なぐりがき

SalesforceからときどきIdol



Salesforce:Force.com IDEのエラー

Eclipseは重いので、使用していなかったのですが、
どうしてもというので、導入しました。
人生で何度目かの。

Eclipseもどうインストールすればいいのか、
ベストを決めておきたい。
いつもAll in One、そして、バージョンに迷う。
たくさんあるけど、違いがわからない。





Deploy to Serverしていたらエラーが出たので、メモ。
英語ぱっと見だと全然わからないので数秒絶望しました。

Google先生にお尋ねしたところ、すぐに回答が返ってきました!
神だよ!!


これ前にもやった気がする。
Eclipseインストール時にiniの設定は必須ですね。
気をつけよう~。

手順としては、Eclipseのインストール⇒eclipse.iniの書き換え⇒
Force.com IDEのインストールって感じですかね。


https://help.salesforce.com/apex/HTViewSolution?id=000004051&language=ja

上記ヘルプページより引用

Force.com IDEのデプロイ時にエラー発生
ナレッジ記事番号 000004051
説明
Force.com IDEのデプロイ時に以下のエラーが発生します。
# Deploy Results:
File Name: package.xml
Full Name: package.xml
Action: NO ACTION
Result: FAILED
Problem: Bad manifest file:Invalid byte 1 of 1-byte UTF-8 sequence
解決策
デプロイ対象のファイルの中に、日本語を使用したものが存在した場合に発生します。
eclipse側の設定ファイル eclipse.ini に以下の記載を追加することで 回避することが可能です。

  • vmargs
  • Dfile.encoding=UTF-8